DVT e Language IDE User Guide
Rev. 19.1.17, 17 May 2019

Chapter 35. Tips and Tricks

The following tips and tricks give some helpful ideas for increasing your productivity.

Editing Source

Searching

Code Navigation and Reading

Miscellaneous

Editing Source

Content assistContent assist provides you with a list of suggested completions for partially entered text. In the e Language editor press Ctrl+Space.


Content assist for enumerated typesYou can use content assist to speed up the access to enum items. Just press Ctrl+Space.


Content assist for macrosYou can use content assist to speed up the access to macros. Just press Ctrl+Space.


Code templatesCode templates are presented in content assist if applicable.



To create your own templates, go to the E Language > Editor > Code Templates preference page and press the New button to create a template. For example, a template for the full syntax of the sequence statement will look like:


Matching bracketsTo find a matching bracket place the cursor after the bracket and press Ctrl+Shift+P or choose Source > Jump To Pair Bracket from the right click menu. You can also double click after the bracket - this selects the text between the two brackets.


Toggle commentYou can toggle comment on/off for the current line or the selected lines. Press Ctrl+/ or from the right click menu in editor Source > Toggle Comment. You can choose the Verilog or the VHDL comment style. Right click in the editor and use the switch comment style action.


Expand/Restore SelectionPress Shift + Alt + Up Arrow to incrementally expand the current selection. For example when the cursor is on a word, select the word. Press again to select the whole line. Then, each of the nested enclosing scopes is selected, for example the current action block, then the enclosing function, then the enclosing struct and so on. The same principle applies to nested enclosing parentheses, brackets and curly braces, as well as strings.


Press Shift + Alt + Down Arrow to restore the previous selection step made with Shift + Alt + Up Arrow.
Format sourceUse the Format Source action from the editor right click menu Source > Format Source. The whole file is formatted or the current selection, if any.
One key indentationIf you press Tab once at the beginning of a line, it is automatically aligned to the enclosing context.Press twice to insert a tab.
Reminders (TODO markers)When you tag a comment in e source code with TODO, a corresponding task is automatically created as a reminder.From the Tasks View, double click on the task takes you to the TODO in the code.Same for for FIXME (higher priority) and XXX (lower priority) markers.You can also add your own tags, see the Reminders (TODO Markers) section of the documentation.



Check Naming ConventionsNaming convention violations are presented as warnings in the Problems View. You can show the Problems View from menu Window > Show View > Other > General > Problems. Double clicking on some warning will jump to the source location.



Naming conventions are automatically checked when building a project. You just need to define them:


- Globally: Go to the Opens the name checks preference page e Language > E Name Checks preference page (via menu Window > Preferences > DVT);


- or Per Project: Right click on the project, choose Properties and go to the E Name Checks preference page.


Spell checkingYou can enable spell-checking support in the e Language editor on the Opens the spelling preference page General > Editors > Text Editors > Spelling preference page. Spelling errors are displayed in the e Language editor and corresponding Quick Fixes are available:



There is currently no dictionary included in Eclipse. The required format is just a list of words separated by new lines.Quick Fixes allow you to add new words to the dictionary on-the-fly.
FoldingYou can fold code sections to improve read-ability. This is how a folded file looks like:



Folding actions (to expand or collapse) are available in the toolbar. You may also use the + or - signs on the left side of the editor.


- Use Collapse All Levels for folding to statement level.


- Use Show First Level for folding to struct member level.


- Use Expand All to fully expand the file. When you type on a folded line, it is automatically expanded. You may see the folded code in a tooltip if you move with the mouse over the + sign.
Folding custom areasYou can define custom folding areas using comments to indicate the start and the end of the area:


Maximize editor Double-click on the editor tab to maximize editor to full window. Double-click again to restore.
Show line numbersCheck Show line numbers from the Opens the general text editor preference page General > Editors > Text Editors preference page
Local historyWhenever you edit a file, its previous contents are kept in the local history. Right click in the editor and choose Compare With/Replace With > Local History....


Go to linePress Ctrl+L shortcut or double click in the status bar to jump to a specific line.



Back/Forward navigationYou can navigate between editors in a browser like way using the Back/Forward Navigation Back/Forward Buttons.
Go to last edit locationUseful when you navigated around in the code, before proceeding with the source change. Click on Last Edit Location button in the toolbar to jump to the file where you were previously editing.
Local historyWhenever you edit a file, its previous contents are kept in the local history. Right click in the editor and choose Compare With/Replace With > Local History....


Inactive code highlightThe editor marks with a colored background the areas of code that are not compiled due to preprocessing. See the Inactive Code Highlight documentation section.


Macro expansionYou can apply preprocessing for a macro called in your code.Place the cursor on the macro, then right click > Macros > Expand All Levels to inspect the expanded macro in a new file.


You can also expand/collapse macros inline using Ctrl Shift = respectively 'Ctrl Shift -'



See the Macro Expansion section in the documentation.
Open file in more editorsTo open multiple editors for the same file you should first open the file then right click on the editor's titlebar and select New Editor


Split the editor viewTo open multiple editors side by side follow these steps:


- open each file in its editor; if you wish to see the same file in a split view, right click on its titlebar and select New Editor


- if you wish to split horizontally, drag the title bar of the file you want to split and drop it over the horizontal scrollbar



- if you wish to split vertically, drag the title bar of the file you want to split and drop it over the vertical scrollbar
Column selectionYou can switch to and from column (block) selection mode either by clicking on the Toggle Block Selection Mode button in the toolbar, or by using the <Shift + Alt + A> shortcut key.


Searching

Search for method, field, event etc.To search for the declaration of a specific type, method, field etc. :


- Press Ctrl+H to open the Search Dialog


- Click on the e Search tab.


- Type the name in the Search String (if you select in the editor before pressing Ctrl+H, the Search String is automatically set to the selection).


- Select type or method etc. and Declarations


- Click Search.


Search for references To search where a method (or field etc.) is used, hold Ctrl, hover over it's name and select Show Usages or right click on it's name > Show > Usages or right click on it's name > References > Project. The results are presented in the Search View. You can also search for references from the Search Dialog (Ctrl+H).


See macro instances To see where a macro is used click on it and press Shift+F3. The results are presented in the Layers View.


Search for whole wordTo search for a whole word in all e files, in comments or not:


* Press Ctrl+H to open the Search Dialog;


- Click on the e Search tab ;


- Type the name in the Search String (if you select in the editor before pressing Ctrl+H, the Search String is automatically set to the selection) ;


- Select Whole Word and Do not search in comments or All occurrences ;


- Click Search.


Code Navigation

TooltipsWhen you position the mouse over a type, method, field etc., a tooltip will pop-up showing information on corresponding declaration.


HyperlinksIf you place the mouse over a type, method, field etc. and press the Ctrl key, a hyperlink will be presented. Click on the hyperlink to jump to definition. You can also jump to a definition if you put the cursor on the relevant name and press F3.


Inheritance tree and members (Type Hierarchy View)You can view the inheritance tree and all the members of a struct by placing the mouse over it and pressing the F4 key. See also Type Hierarchy View.


Verification Hierarchy of a unit (Verification Hierarchy View)You can view the Verification Hierarchy View of a unit (including ports) by placing the mouse over it and pressing Shift+F6.
Class DiagramsYou can create class diagrams to inspect or document the architecture of a verification environment. For more details see the Diagrams -> Class Diagrams
Macro Hyperlinks and Tooltips If you place the mouse over a macro you'll see a tooltip with the documentation. Define as macro tooltip example:



Preprocessing define tooltip example:



If you press the Ctrl key, a hyperlink will be presented. Click on the hyperlink to jump to definition.You can also jump to a definition if you put the cursor on the relevant name and press F3.


ScopeYour current scope (for example the method or struct you are editing) is always presented in the status bar.


Quick TypesYou can quickly open a specific type definition, just press Ctrl+Shift+T. The Quick Types View will pop-up and you can enter any regular expression to locate a type. Select and press Enter or click to jump to its definition.


Quick MacrosPress Ctrl+Shift+D to open the Quick Macros View. It presents the available macros, both preprocessing and define as. You can enter any regular expression to locate a macro and jump to its definition (select and press Enter or click).


Quick OutlinePress Ctrl+O to open the Quick Outline View. It presents an overview of your file. You can enter any regular expression to locate a place to jump in the current file.


Quick LayersPress Ctrl+Shift+O with the cursor positioned on the name to quickly see extensions.


Quickly jump to a layer of a field's typePress Ctrl+Shift+O twice with the cursor positioned on the field name (first time shows the field layers, second time the layers of the type of the field). Then you can use the filter to jump to the desired layer.
Quick Compile OrderYou can quickly open a compiled file. Just press Ctrl+I.The Quick Compile Order View will pop-up and you can enter any regular expression to locate a file. Select and press Enter or click to open the file.


Quick HierarchyPosition the cursor on the struct name and press Ctrl+T to see the Quick Type Hierarchy View.


LayersYou can view all the extensions (layers) of a specific type, method, event etc. Position the cursor on the relevant name and press Shift+F3 or right click and choose Show > Layers from the menu. See Layers View.


Event LayersLayers include on and cover definition.Position the cursor on the event name and press Shift+F3 or right click and choose Show Layers from the menu. See also Layers View.


TypesYou can view all types (enums, structs) in the project (including each struct fields, methods etc.) in the Types View. Open the view from menu Window > Show View > Other... > DVT > Types.
ChecksYou can view all the checks ("check that", "expect", "assert", "assume") in the project in the Checks View. Open the view from menu Window > Show View > Other... > DVT > Checks.


CoverageYou can browse all the coverage definitions in the project using the Coverage View. Open the view from menu Window > Show View > Other... > DVT > Coverage.


MacrosYou can see the macros in your project in the Macros View.Open the view from menu Window > Show View > Other... > DVT > Macros. Double click to jump to macro definition.


Compile OrderYou can see the compile order of the files in your project in the Compile Order View. Open the view from menu Window > Show View > Other... > DVT > Compile Order.


OutlineYou can see the summary contents of the current file (structs, field, methods) in the Outline View. Open the view from menu Window > Show View > Other... > General > Outline.


Mark occurrencesWhen working in the e Language editor, turn on Mark Occurrences in the toolbar or press Alt+Shift+O.


Override Annotations Override Annotations are markers that display special decoration icons to indicate that a method or TCM overrides a like super-type.


BookmarksSimilar with a web browser, you can add bookmarks in your code without altering the code. Right click on the left vertical bar of the editor and choose Add Bookmark...



Specify a meaningful name:



You can jump to bookmarks from Bookmarks View. Open the view from menu Window > Show View > Other... > General > Bookmarks.


Miscellaneous

All shortcutsPress Ctrl+Shift+L to see all shortcuts.


Project PropertiesSelect the project in the Navigator View, right click and choose Properties.Or from menu Project > Properties.
OVM Compliance ReviewTo perform the OVM compliance review of your project click the lint button in the toolbar
. For more details see the OVM Compliance Review chapter in EDT User Guide.
Project TemplatesA project template is a parameterized directory tree. Both in the file contents (.e, ,.sh - practically any file) and in the file or directory names you can use parameters.Combined with TODO markers, you can use a project template as a customized wizard.For more details see the Project Templates chapter in EDT User Guide.
System VariablesSee: Build_Configurations
Generic launch (make, scripts etc.)See: Run_Configurations
Create dialogs for scripts & flowsYou can create Custom Dialogs for your own scripts:



Follow the wizrd from menu New > Example > DVT > DVT Custom Dialog, then create a run configuration with the command echo ${dvt_dialog_prompt:customdialog.swtxml} and run it.
Open terminalYou can open a fully working command-line terminal inside of DVT: In the Navigator View right-click on the desired location and select Open Terminal Here
Load in SpecmanRight click on a file in Navigator (usually top or test) and from menu Run As choose Load in Specman.



The invocation output is dumped to the Console View. Click on hyperlinks in the Console View to jump directly to the to source location.


External BuildersAn external builder allows you to invoke any script/tool and back-annotate its output (errors, warnings etc.) to the source code. Practically it allows you to connect any 3d party tool (compiler, linter etc.) to DVT error signaling engines. For more details see External Builders.
External DocumentationYou can browse and search through 3rd party documentation using the Eclipse help system.For more details see the External Tools > External Documentation chapter in EDT User Guide.
Context Sensitive HelpA focused set of help topics that is related to the current context can be shown to users on demand using context-sensitive help. This form of user assistance is delivered to users when a platform-specific trigger is activated (e.g. F1 key on Windows, Ctrl+F1 on GTK, Help key on Carbon).For more details see the Getting Started > Context Sensitive Help chapter in EDT User Guide.


Mapping Linux to Windows (/proj/ to Z:\proj\)Linux directories can be mapped to Windows drives in order to access them from Windows. For example /home/simi is mapped to Z:\. This has an impact on paths configured for a DVT project, for example INCDIRs etc. The paths are set using Linux conventions, however Eclipse runs in Windows and the DVT builder needs to know about the mapping in order to compile the files. To specify the mapping, set the system variable %DVT_CROSSPLATFORM_MAP% before invoking Eclipse. You can add multiple mappings separated by ";" e.g.: /projects/=p:\;/home/lars/=Z:\lars\
Recover from abnormal inconsistenciesIn the event of a disfunction (missing results in search, types in type browsing, hyperlinks, tooltips etc.) please manually trigger a rebuild .
Add a new file extension to compile list extensionsGo to Window > Preferences > General > Content Types, select a category from the list (for example e Source File) then click on Add and then on Ok.


Share workspace settingsExport all Workspace/ Eclipse customization:- Go to File > Export > General > Preferences - Make sure Export all is selected - Select a file where the preferences should be exported. Now you can share this file with your team. When it is imported into another instance of Eclipse (by using File > Import > General > Preferences), the configuration (all options available in Window > Preferences) is replaced by the imported one. Note: you should restart Eclipse for the changes to be enforced ( File > Restart).


Using System Varibles in Linked Resources You can use System Variables in the path of linked resources. For example ${DVT_ENV-SYSTEM_VARIABLE_NAME}/work is equivalent to $SYSTEM_VARIABLE_NAME/work in a console.
Waive problems reported by DVTYou can use Compile Waivers to promote, demote or disable the problems reported by DVT.


To quickly create a new waiver, in the Problems View right click on any problem reported by DVT and waive it. DVT proposes some default values for the waiver description, path and message. You can easily change them to fine-tune the waiver.


To quickly start up a new waivers file click on the Edit waivers button in the Problems View. The .dvt/waivers.xml is created with a default content and opened. You can easily create your own waivers from the default generated ones.


In the waivers editor you can use autocomplete for tags, attributes and attribute values.
Open a file in DVT from the terminalYou can use the Command Line Interface like this:


$> dvt_cli.sh -workspace ~/dvt_workspace openFile $(readlink -f my/file.sv)


The command can be shortened by defining this alias in your ~/.cshrc:


alias dvtopen 'dvt_cli.sh -workspace ~/dvt_workspace openFile `readlink -f \!*`'


or by defining this function in your ~/.bashrc:


dvtopen () { dvt_cli.sh -workspace ~/dvt_workspace openFile $(readlink -f $1); }


Then the command gets much shorter:


$> dvtopen my/file.sv